Ubuntu 14.04 unmet dependencies when installing Wine

[email protected]:~$ sudo apt-get install wine
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
wine : Depends: wine1.6 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

After a hour of trial and error,
I found out that the problem was caused by outdated software source.
Just changed back to “archive.ubuntu.com” and dependency error is fixed.
(The broken server is ubuntu.01link.hk)

Be careful when using 3rd party software sources!
You can check if a mirror is up-to-date here.